Minimum requirements: Android OS 2.3.3 or above; Unlimited internet data plan recommended; Tablet devices are not supported; Third-Party Sources: qcom.c: LGPL 2.1 …